Monitoring Hurricane Harvey
Incident Report for Traveling Mailbox, LLC
Resolved
Our Houston location has confirmed that it is back processing mail as usual. Thanks to everyone for their patience during this incident.
Posted about 1 year ago. Sep 07, 2017 - 09:52 EDT
Monitoring
The Traveling Mailbox Team is Monitoring the Status of Hurricane Harvey and its impacts. We do operate addresses out of the Texas area including Houston.

At this time, we are expecting several days of disruption with our Houston, TX Location but the full extent of that will not be known until this weekend.

We will continue to post updates here with what we learn and what customers can expect.
Posted about 1 year ago. Aug 25, 2017 - 21:57 EDT