We are currently investigating an issue with our main website loading.
Incident Report for Traveling Mailbox, LLC
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 02, 2019 - 10:59 EDT
Monitoring
Services appear to be returning online. We will be monitoring and will mark the outage as resolved once we are confident everything is good to go. Thank you for your patience.
Posted 4 months ago. Jul 02, 2019 - 10:12 EDT
Update
We are continuing to work on a fix for this issue.
Posted 4 months ago. Jul 02, 2019 - 10:01 EDT
Identified
The issue appears to be with one of our vendors which is aware of the problem and are working to mitigate the issues.
Posted 4 months ago. Jul 02, 2019 - 09:57 EDT
Investigating
We are currently experiencing an outage with our main website that we are investigating. All Mailbox accounts are unaffected and can be reached at https://my.travelingmailbox.com
Posted 4 months ago. Jul 02, 2019 - 09:51 EDT
This incident affected: TMB Main Website.