My.TravelingMailbox.com Outage
Incident Report for Traveling Mailbox, LLC
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 08, 2019 - 09:53 EST
Identified
The Mailbox Portal is back online. We are working to see what caused the issue and implementing fixes to prevent the issue from reoccurring.
Posted 8 months ago. Feb 08, 2019 - 09:44 EST
Investigating
We are investigating an outage with our Mailbox Portal. We will post updates as we have them.
Posted 8 months ago. Feb 08, 2019 - 09:38 EST
This incident affected: Online Mailbox Portal.