Live Chat Currently Unavailable
Incident Report for Traveling Mailbox, LLC
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 13, 2019 - 11:03 EDT
Update
We are continuing to monitor for any further issues.
Posted 2 months ago. Jun 13, 2019 - 10:57 EDT
Update
We have just been notified that the effected services have been fixed. However, we will continue to monitor.
Posted 2 months ago. Jun 13, 2019 - 10:57 EDT
Update
Just a further note: No Traveling Mailbox Services are effected by this outage.
Posted 2 months ago. Jun 13, 2019 - 10:56 EDT
Monitoring
Our Live Chat Vendor is currently experiencing technical difficulties. As a result, we are unable to utilize our Live Chat Feature for the time being. We will post when services resume to a normal state.
Posted 2 months ago. Jun 13, 2019 - 10:53 EDT
This incident affected: Third Party Components (LiveChat Chat widget).