Customer Portal Currently Down
Incident Report for Traveling Mailbox
Resolved
This incident has been resolved.
Posted Jan 13, 2020 - 10:49 EST
Update
We are continuing to monitor for any further issues.
Posted Jan 13, 2020 - 10:47 EST
Monitoring
A fix has been implemented and the site has returned online. We apologize for the inconvenience.
Posted Jan 13, 2020 - 10:46 EST
Identified
Our Developers have identified the problem and are actively working to fix the issue.
Posted Jan 13, 2020 - 10:46 EST
Investigating
The main customer portal at my.travelingmailbox.com is currently down. Our Developers are currently investigating.
Posted Jan 13, 2020 - 10:24 EST
This incident affected: Online Mailbox Portal.