Hurricane Florence
Incident Report for Traveling Mailbox, LLC
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 17, 2018 - 09:18 EDT
Monitoring
The Traveling Mailbox Team is Monitoring Hurricane Florence as it approaches North Carolina. We expect the storm to disrupt our normal operations beginning Friday Sept. 14. During this time processing is expected to be degraded and outgoing shipments delayed until the following week. Phone Support may be unavailable as well.

If you need assistance, please email us at Support@TravelingMailbox.com and we will respond as soon as possible.
Posted about 1 year ago. Sep 12, 2018 - 22:12 EDT
This incident affected: Mail Processing & Forwarding and Phone Support.