Service Outage
Incident Report for Traveling Mailbox
Resolved
This incident has been resolved.
Posted Apr 22, 2021 - 16:59 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2021 - 16:39 EDT
Update
Technicians are enroute to our location to perform repairs. We expect them to be on site within the hour. All services are online and operating normally on our additional service providers with the exception of our phones. Phone Support is still currently unavailable.
Posted Apr 22, 2021 - 15:44 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 22, 2021 - 14:03 EDT
Identified
We have lost a circuit link from one of our Internet Providers. We are checking to see what the ETA is. During this time, we will be unable to accept calls for Sales & Support. We apologize for the inconvenience.
Posted Apr 22, 2021 - 14:02 EDT
Investigating
We are currently having network infrastructure issues that may impact our services.
Posted Apr 22, 2021 - 13:51 EDT
This incident affected: Online Mailbox Portal, TMB Main Website, Traveling Mailbox Datacenter, and Phone Support.