My.TravelingMailbox.com Outage
Incident Report for Traveling Mailbox, LLC
Resolved
All set! Our Engineers have resolved the problem. We apologize for the inconvenience.
Posted 15 days ago. Jun 09, 2019 - 09:52 EDT
Monitoring
All fixes have been implemented and we are monitoring. Services appear to be returning online.
Posted 15 days ago. Jun 09, 2019 - 09:48 EDT
Update
We are continuing to investigate this issue.
Posted 15 days ago. Jun 09, 2019 - 09:30 EDT
Investigating
We are currently experiencing an outage with our primary mailbox server. Our Engineers are actively working on the issue now.
Posted 15 days ago. Jun 09, 2019 - 09:30 EDT
This incident affected: Online Mailbox Portal.