Video on Homepage
Incident Report for Traveling Mailbox, LLC
Resolved
The outage at Vimeo seems to have resolved at this time. We will continue to monitor.
Posted almost 2 years ago. Mar 14, 2016 - 14:52 EDT
Identified
Engineers at Vimeo are advising that there are issues loading the video players. Vimeo engineers are working to resolve the problem as soon as possible.
Posted almost 2 years ago. Mar 14, 2016 - 13:26 EDT
Investigating
We are currently investigating an issue with our video that plays on our homepage. This issue seems to be with the Video Provider.
Posted almost 2 years ago. Mar 14, 2016 - 13:23 EDT