Slow Processing
Incident Report for Traveling Mailbox
Resolved
Scan times have returned to their normal state. Note: January and February are the busiest months of the year for Traveling Mailbox when it comes to mail volume due to the tax season. We will continue to work to keep ahead of the pace. We apologize for the inconvenience and thank you for your patience.
Posted Jan 07, 2020 - 10:07 EST
Monitoring
Due to the holidays and the inconsistency of mail & package deliveries, our system of processing is currently imbalanced. We have received an abnormally high volume of mail and it has put us behind on our processing. As a result, customers are seeing longer than normal processing times on their requests.

As you know, Traveling Mailbox operates on the weekends as well so we will be bringing in additional staff to help get things back on track. We sincerely apologize for the inconvenience and the delays.
Posted Jan 03, 2020 - 11:40 EST
This incident affected: Mail Processing & Forwarding.