We are continuing to monitor for any further issues.
Posted 27 days ago. May 22, 2025 - 13:24 EDT
Monitoring
Services have been restored to https://my.travelingmailbox.com. We are continuing to monitor and perform necessary functions to ensure system stability. Thank you for your patience.
Posted 27 days ago. May 22, 2025 - 10:41 EDT
Identified
We have identified the issue and our engineers are actively working to correct the issue. Thank you for your patience.
Posted 27 days ago. May 22, 2025 - 10:22 EDT
Investigating
The main website is currently down again. Our Engineers are investigating again.
Posted 27 days ago. May 22, 2025 - 09:56 EDT
Update
Services have recovered at this time. We are continuing to monitor the site and perform any remaining necessary operations. Thank you for your patience.
Posted 27 days ago. May 22, 2025 - 08:18 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 27 days ago. May 22, 2025 - 07:23 EDT
Identified
Services are beginning to recover at this time. Thank you for your patience.
Posted 27 days ago. May 22, 2025 - 07:23 EDT
Update
Our engineers are actively looking into the issue at this time. Thank you for your patience.