Regional Network Issues

Incident Report for Traveling Mailbox

Resolved

This incident has been resolved.
Posted 4 years ago. Jan 19, 2021 - 14:24 EST

Monitoring

We are continuing to monitor but our tests and our systems are improving.
Posted 4 years ago. Jan 19, 2021 - 09:41 EST

Investigating

We are currently investigation regional network issues that are impacting our services. Billing is primarily impacted at this time.
Posted 4 years ago. Jan 19, 2021 - 09:11 EST
This incident affected: TMB Main Website.