Unable to accept phone calls
Incident Report for Traveling Mailbox
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 16:42 EST
Monitoring
We appear to be able to receive calls at this time through our toll-free number. We will continue to monitor.
Posted Feb 27, 2024 - 13:17 EST
Investigating
We are experiencing issues receiving phone calls through our support system. We can be reached at 919-564-6631 or via Chat and Email. Thanks for your patience.
Posted Feb 27, 2024 - 12:19 EST
This incident affected: Support Channels.