We are continuing to investigate this issue and we are going to be performing remediation steps shortly.
Posted Dec 27, 2025 - 20:09 EST
Investigating
The Traveling Mailbox Network is currently experiencing technical difficulties. We are engaging our support teams at this time. This issue is related to some new hardware that was recently installed.
Posted Dec 27, 2025 - 18:33 EST
This incident affected: Online Mailbox Portal, TMB Main Website, and Traveling Mailbox Datacenter.