Issues with our Live Chat
Incident Report for Traveling Mailbox
Resolved
Our Live Chat vendor has indicated that the previous issues have been resolved.
Posted Feb 24, 2022 - 13:39 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2022 - 12:49 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 24, 2022 - 11:45 EST
Investigating
Our Live Chat vendor is currently investigating issues within their software that is effecting our Live Chat. Customers may be unable to chat with us and we may be unable to respond to support tickets via email. Please contact us via Phone at 855-749-1737.
Posted Feb 24, 2022 - 10:39 EST
This incident affected: Support Channels.