Issue with Third Party Vendor
Incident Report for Traveling Mailbox
Resolved
This incident has been resolved. The Vendor is a core third party service that services Traveling Mailbox. The outage was caused by a configuration error that caused a core network router to get overwhelmed. This issue has been confirmed fixed by the vendor. Thank you for your patience and we apologize for the inconvenience.
Posted Jul 18, 2020 - 07:16 EDT
Monitoring
Services are returning to normal. We will continue to monitor.
Posted Jul 17, 2020 - 17:37 EDT
Identified
Due to an issue with a Third Party Vendor, Traveling Mailbox websites may be unreachable. We are currently investigating.
Posted Jul 17, 2020 - 17:24 EDT
This incident affected: Online Mailbox Portal and TMB Main Website.