Network Degradation

Incident Report for Traveling Mailbox

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 02:54 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2026 - 02:46 EST

Identified

The issue has been identified and we are taking remediation steps at this time to restore our network. Thank you for your patience.
Posted Jan 14, 2026 - 02:16 EST

Update

Due to this hardware error, the Traveling Mailbox network is currently down. We are working diligently to resolve the issue to stabilize the network before operating hours. Thank you for your patience.
Posted Jan 14, 2026 - 02:00 EST

Update

Our teams are continuing to investigate this issue. The issue is related to new hardware that has been recently installed in our Datacenter.
Posted Jan 14, 2026 - 00:58 EST

Update

We are continuing to investigate this issue.
Posted Jan 13, 2026 - 23:26 EST

Investigating

We are currently investigating this issue.
Posted Jan 13, 2026 - 21:23 EST
This incident affected: Online Mailbox Portal, TMB Main Website, and Traveling Mailbox Datacenter.